<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US"
xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<title>Learn about improvements planned to Power Road at open house Aug. 30 - Queen Creek Independent | Queen Creek Independent</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<!-- <link rel="stylesheet" type="text/css" media="all" href="http://queencreekindependent.com/wp-content/themes/newswire/style.css" /> -->
<link rel="alternate" type="application/rss+xml" title="Queen Creek Independent RSS Feed" href="http://queencreekindependent.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="Queen Creek Independent Atom Feed" href="http://queencreekindependent.com/feed/atom/" />
<link rel="pingback" href="http://queencreekindependent.com/xmlrpc.php" />
<!-- <link rel="stylesheet" type="text/css" href="http://queencreekindependent.com/wp-content/themes/newswire/colors/default.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="http://queencreekindependent.com/wp-content/themes/newswire/css/media-queries.css" /> -->
<!-- <link rel="stylesheet" type="text/css" href="http://queencreekindependent.com/wp-content/themes/newswire/custom.css" /> -->
<link rel="stylesheet" type="text/css" href="//queencreekindependent.com/wp-content/cache/wpfc-minified/e94a5080762048456160fb2580a132c6/1493838606index.css" media="all"/>
<!--[if lt IE 9]>
<script src="http://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
<![endif]-->
<!--Plugin WP Missed Schedule 2013.1231.2013 Build 2014-09-13 Active - Tag 6707293c0218e2d8b7aa38d418ffa608-->
<!-- This website is patched against a big problem not solved from WordPress 2.5+ to date -->
<!-- MapPress Easy Google Maps Version:2.45 (http://www.wphostreviews.com/mappress) -->
<script type='text/javascript'>mapp = window.mapp || {}; mapp.data = [];</script>
<!-- This site is optimized with the Yoast SEO plugin v5.3.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://queencreekindependent.com/news/learn-improvements-planned-power-road-open-house-aug-30/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Learn about improvements planned to Power Road at open house Aug. 30 - Queen Creek Independent" />
<meta property="og:description" content="The town of Queen Creek is hosting a community open house to provide information on improvements to Power Road from Ocotillo to Brooks Farm roads. It will be held 6-7 p.m. Wednesday, Aug. 30, in the Founders Room of Historic Town Hall, 22350 S. Ellsworth Road. Roadway improvements include widening Power Road to three lanes &hellip;" />
<meta property="og:url" content="http://queencreekindependent.com/news/learn-improvements-planned-power-road-open-house-aug-30/" />
<meta property="og:site_name" content="Queen Creek Independent" />
<meta property="article:publisher" content="http://www.facebook.com/QueenCreekSanTanValleyIndependent" />
<meta property="article:tag" content="Featured" />
<meta property="article:tag" content="Power Road" />
<meta property="article:tag" content="Queen Creek" />
<meta property="article:tag" content="Road Improvements" />
<meta property="article:section" content="Queen Creek/San Tan Valley News" />
<meta property="article:published_time" content="2017-08-25T04:36:57+00:00" />
<meta property="fb:app_id" content="1586322298303559" />
<meta property="og:image" content="http://queencreekindependent.com/wp-content/uploads/2015/12/LOGO-QC-Better-Roads-Ahead.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="495" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The town of Queen Creek is hosting a community open house to provide information on improvements to Power Road from Ocotillo to Brooks Farm roads. It will be held 6-7 p.m. Wednesday, Aug. 30, in the Founders Room of Historic Town Hall, 22350 S. Ellsworth Road. Roadway improvements include widening Power Road to three lanes [&hellip;]" />
<meta name="twitter:title" content="Learn about improvements planned to Power Road at open house Aug. 30 - Queen Creek Independent" />
<meta name="twitter:site" content="@QCIndependent" />
<meta name="twitter:image" content="http://queencreekindependent.com/wp-content/uploads/2015/12/LOGO-QC-Better-Roads-Ahead.jpg" />
<meta name="twitter:creator" content="@QCIndependent" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/queencreekindependent.com\/","name":"Queen Creek Independent","potentialAction":{"@type":"SearchAction","target":"http:\/\/queencreekindependent.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/queencreekindependent.com\/news\/learn-improvements-planned-power-road-open-house-aug-30\/","sameAs":["http:\/\/www.facebook.com\/QueenCreekSanTanValleyIndependent","https:\/\/twitter.com\/QCIndependent"],"@id":"#organization","name":"Queen Creek \/ San Tan Valley Independent","logo":"http:\/\/queencreekindependent.com\/wp-content\/uploads\/2015\/05\/arizona-favicon.jpg"}</script>
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queen Creek Independent &raquo; Feed" href="http://queencreekindependent.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Queen Creek Independent &raquo; Comments Feed" href="http://queencreekindependent.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Queen Creek Independent &raquo; Learn about improvements planned to Power Road at open house Aug. 30 Comments Feed" href="http://queencreekindependent.com/news/learn-improvements-planned-power-road-open-house-aug-30/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/queencreekindependent.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<meta content="/home/queencreekindepe/public_html/wp-content/themes/newswire/style.css v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<!-- <link rel='stylesheet' id='simple-payments-css'  href='http://queencreekindependent.com/wp-content/plugins/jetpack/modules/simple-payments/simple-payments.css?ver=4.8.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='shortcodes-css'  href='http://queencreekindependent.com/wp-content/themes/newswire/functions/shortcodes/shortcodes.css?ver=4.8.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='cptch_stylesheet-css'  href='http://queencreekindependent.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.3.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='dashicons-css'  href='http://queencreekindependent.com/wp-includes/css/dashicons.min.css?ver=4.8.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='cptch_desktop_style-css'  href='http://queencreekindependent.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.3.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mappress-css'  href='http://queencreekindependent.com/wp-content/plugins/mappress-google-maps-for-wordpress/css/mappress.css?ver=2.45' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='junkie-shortcodes-css'  href='http://queencreekindependent.com/wp-content/plugins/theme-junkie-shortcodes/assets/css/junkie-shortcodes.css?ver=4.8.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='__EPYT__style-css'  href='http://queencreekindependent.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=4.8.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//queencreekindependent.com/wp-content/cache/wpfc-minified/3ed31d4e4bca21c796887e9771491b4b/1501644037index.css" media="all"/>
<style id='__EPYT__style-inline-css' type='text/css'>
.epyt-gallery-thumb {
width: 33.333%;
}
</style>
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.8.1' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='jetpack_css-css'  href='http://queencreekindependent.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.2.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//queencreekindependent.com/wp-content/cache/wpfc-minified/409362f32db6e114f9f7302ce86d98da/1493838606index.css" media="all"/>
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js?ver=1.10.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/queencreekindependent.com\/wp-admin\/admin-ajax.php","security":"28237d1f28","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/queencreekindependent.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"11.8.2","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script src='//queencreekindependent.com/wp-content/cache/wpfc-minified/b4387ed8ffb2965d8dacf0602b6084eb/1501712506index.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='http://queencreekindependent.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=4.8.1'></script> -->
<!-- <script type='text/javascript' src='http://queencreekindependent.com/wp-content/themes/newswire/functions/shortcodes/shortcodes.js?ver=1.0.0'></script> -->
<!-- <script type='text/javascript' src='http://queencreekindependent.com/wp-content/themes/newswire/includes/js/jquery-ui-1.8.5.custom.min.js?ver=1.8.5'></script> -->
<!-- <script type='text/javascript' src='http://queencreekindependent.com/wp-content/themes/newswire/includes/js/superfish.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='http://queencreekindependent.com/wp-content/themes/newswire/includes/js/custom.js?ver=1.4.2'></script> -->
<!-- <script type='text/javascript' src='http://queencreekindependent.com/wp-content/themes/newswire/includes/js/scrolltop.js?ver=1.0'></script> -->
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=1.0'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='http://queencreekindependent.com/wp-json/' />
<meta name="generator" content="WordPress 4.8.1" />
<link rel='shortlink' href='http://wp.me/p7BzGt-2Ph' />
<link rel="alternate" type="application/json+oembed" href="http://queencreekindependent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fqueencreekindependent.com%2Fnews%2Flearn-improvements-planned-power-road-open-house-aug-30%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://queencreekindependent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fqueencreekindependent.com%2Fnews%2Flearn-improvements-planned-power-road-open-house-aug-30%2F&#038;format=xml" />
<meta property="fb:app_id" content="1586322298303559"/>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel="shortcut icon" href="http://queencreekindependent.com/wp-content/uploads/2015/05/arizona-favicon.jpg" /><!-- Custom Styling -->
<style type="text/css">
body { }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ff6600; }
</style>
<link rel="amphtml" href="http://queencreekindependent.com/news/learn-improvements-planned-power-road-open-house-aug-30/amp/" /><!-- custom CSS -->
<link rel="stylesheet" type="text/css" href="http://delawarestatenews.net/inicustom.css"/>
<!-- Doubleclick -->
<script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/83779297/az-leaderboard-01', [728, 90], 'div-gpt-ad-1430931892893-0').addService(googletag.pubads());
googletag.defineSlot('/83779297/az-mediumrectangle-01', [300, 250], 'div-gpt-ad-1430931892893-1').addService(googletag.pubads());
googletag.defineSlot('/83779297/az-mediumrectangle-02', [300, 250], 'div-gpt-ad-1430931892893-2').addService(googletag.pubads());
googletag.defineSlot('/83779297/az-mediumrectangle-03', [300, 250], 'div-gpt-ad-1430931892893-3').addService(googletag.pubads());	
googletag.defineSlot('/83779297/az-mediumrectangle-02', [300, 250], 'div-gpt-ad-1466175924688-0').setTargeting('page', ['sheriff and fire']).addService(googletag.pubads());
googletag.defineSlot('/83779297/az-mediumrectangle-02', [300, 250], 'div-gpt-ad-1488831858687-0').setTargeting('page', ['sports']).addService(googletag.pubads());
googletag.defineSlot('/83779297/az-mediumrectangle-02', [300, 250], 'div-gpt-ad-1502892667564-0').setTargeting('page', ['entertainment']).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('community', 'east valley');
googletag.pubads().setTargeting('community', 'queen creek');
googletag.pubads().enableSyncRendering();
googletag.enableServices();
});
</script>
<!--  Google Analytics -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-62656143-1', 'auto');
ga('send', 'pageview');
</script>			<style type="text/css" id="wp-custom-css">
/*
You can add your own CSS here.
Click the help icon above to learn more.
*/
@media only screen and (max-width: 767px) {
.footer-categories {
display: block;
height: auto;
margin-bottom: 5px;
}
}
</style>
</head>
<body class="post-template-default single single-post postid-10867 single-format-standard custom-background unknown">
<div id="wrapper">
<div id="primary-nav">
<ul id="primary-navigation" class="nav"><li id="menu-item-1726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1726"><a href="#">Reader Services</a>
<ul  class="sub-menu">
<li id="menu-item-47" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47"><a href="http://queencreekindependent.az.newsmemory.com/">E-newspaper</a></li>
<li id="menu-item-1725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1725"><a href="http://www.newslibrary.com/sites/qcib/">Online Print Archive</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44"><a href="http://arizonaclassifieds.newszap.com/">This Week&#8217;s Ads</a></li>
</ul>
</li>
<li id="menu-item-2166" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2166"><a href="http://www.arizonaclassifieds.newszap.com/">Classifieds</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43"><a href="http://arizonaclassifieds.newszap.com/marketplace/">BizSearch</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-45"><a href="http://www.legacy.com/obituaries/newszapaz/">Obituaries</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46"><a href="http://specialsections.newszap.com/SS/Tiles2.aspx?sortby=type&#038;type=Arizona">Special Sections</a></li>
<li id="menu-item-42" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42"><a href="http://queencreekindependent.com/enewsletter/">Enewsletter</a></li>
<li id="menu-item-1246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1246"><a href="http://queencreekindependent.com/find/">Find the Independent</a></li>
</ul>		<form method="get" id="searchform" action="http://queencreekindependent.com">
<fieldset>
<input type="text" name="s" id="s" placeholder="Search" />
</fieldset>
</form>
</div><!-- #primary-nav -->
<div id="header">
<a href="http://queencreekindependent.com"><img src="http://queencreekindependent.com/wp-content/uploads/2016/04/New-online-QC-logo.jpg" alt="Queen Creek Independent" id="logo"/></a>
<div class='header-ad'><!-- /83779297/az-leaderboard-01 -->
<div id='div-gpt-ad-1430931892893-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430931892893-0'); });
</script>
</div></div>		<a class="button-menu" id="toggle" href="#"></a>			
<div class="clear"></div> 
</div><!-- #header-->
<div id="secondary-nav">
<ul id="secondary-navigation" class="nav"><li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="http://queencreekindependent.com/section/news/">News</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32"><a href="http://queencreekindependent.com/section/pinal-maricopa-county/">Pinal/Maricopa County</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27"><a href="http://queencreekindependent.com/section/east-valley-state/">East Valley/State</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26"><a href="http://queencreekindependent.com/section/business/">Business</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28"><a href="http://queencreekindependent.com/section/education/">Education</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30"><a href="http://queencreekindependent.com/section/opinion/">Opinion</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31"><a href="http://queencreekindependent.com/section/galleries/">Galleries</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="http://queencreekindependent.com/section/sheriff-and-fire/">Sheriff and Fire</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="http://queencreekindependent.com/section/sports-and-outdoors/">Sports</a></li>
</ul>	</div><!-- #secondary-nav -->
<div id="main">
<div id="content">
<p id="breadcrumbs"><span xmlns:v="http://rdf.data-vocabulary.org/#"><span typeof="v:Breadcrumb"><a href="http://queencreekindependent.com/" rel="v:url" property="v:title">Home</a>  <span rel="v:child" typeof="v:Breadcrumb"><a href="http://queencreekindependent.com/section/news/" rel="v:url" property="v:title">Queen Creek/San Tan Valley News</a>  <strong class="breadcrumb_last">Learn about improvements planned to Power Road at open house Aug. 30</strong></span></span></span></p>
<div id="post-10867" class="post-10867 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-featured tag-power-road tag-queen-creek tag-road-improvements byline-queen-creek-independent-staff-report">
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_sharing_toolbox"></div>
<h1 class="entry-title">Learn about improvements planned to Power Road at open house Aug. 30</h1>
<div class="entry-meta">
<span class="entry-date">Aug 25th, 2017</span> &middot; by <a href="http://queencreekindependent.com/byline/queen-creek-independent-staff-report/" rel="tag">Queen Creek Independent staff report</a> &middot;<span class="entry-comment"> Comments: <fb:comments-count href="http://queencreekindependent.com/news/learn-improvements-planned-power-road-open-house-aug-30/"></fb:comments-count></span>
</div><!-- .entry-meta -->
<div class="entry-content">
<p>The town of Queen Creek is hosting a community open house to provide information on improvements to Power Road from Ocotillo to Brooks Farm roads.</p>
<p>It will be held 6-7 p.m. Wednesday, Aug. 30, in the Founders Room of Historic Town Hall, 22350 S. Ellsworth Road.</p>
<p>Roadway improvements include widening Power Road to three lanes in each direction with a center turn lane, curb, gutter and sidewalks, according to a press release.</p>
<p>The project also will include undergrounding of utilities, street lights, bike lanes, irrigation improvements and construction of a box culvert crossing at the Sonoqui Wash.</p>
<p>Construction is anticipated to begin later this year.</p>
<p>The following town projects are also in the design phase with construction beginning in the near future:</p>
<p>•Crismon Road from Queen Creek Road to Germann Road: The project consists of paving, curb and gutter to extend Crismon Road north from Queen Creek Road to Germann Road with one lane in each direction. It will also include intersection and streetlight improvements. Construction is anticipated to begin this fall.</p>
<p>•Ellsworth Road from Empire Road to Hunt Highway: Widening Ellsworth Road south of Empire Boulevard. Improvements also include installing curb and gutter, raised medians and streetlights on the east side of the road. A new traffic signal and box culvert will also be installed. Construction is anticipated to being this fall.</p>
<p>•Ellsworth and Queen Creek intersection (Phase 2): Realignment and softening of the Ellsworth Road curve at the Queen Creek Road intersection. The intersection will shift slightly north to improve traffic flow and movement.<br />
The project also includes street, drainage, irrigation, waterline, sidewalk, landscape and traffic signal improvements from Walnut Road to Fulton Parkway and slightly east on Queen Creek Road. Construction is expected to begin later this year.</p>
<p>•The Maricopa County Department of Transportation is improving Riggs Road from Recker Road to Meridian Road in partnership with the town of Queen Creek.</p>
<p>The improvements are being completed in phases. Improvements between Recker and Power are nearing completion with improvements from Power to Hawes and Ellsworth to Crismon beginning this fall.</p>
<p>For more information about the town’s capital improvement program, visit <a href="http://QueenCreek.org/BetterRoadsAhead">QueenCreek.org/BetterRoadsAhead</a>.</p>
<ul><p><em></em></p></ul>
<div class="entry-tags"><span>Tags:</span><a href="http://queencreekindependent.com/tag/featured/" rel="tag">Featured</a> &middot; <a href="http://queencreekindependent.com/tag/power-road/" rel="tag">Power Road</a> &middot; <a href="http://queencreekindependent.com/tag/queen-creek/" rel="tag">Queen Creek</a> &middot; <a href="http://queencreekindependent.com/tag/road-improvements/" rel="tag">Road Improvements</a></div>		  		<div class="clear"></div>
</div><!--end .entry-->
<div class="entry-related">
<h3 class="section-title">Related Posts</h3>
<ul class="related-loop">		
<li >
<a href="http://queencreekindependent.com/community-event/american-legion-post-no-129-honor-first-responders-dinner/" rel="bookmark"><img width="120" height="80" src="http://queencreekindependent.com/wp-content/uploads/2017/08/LOGO-AmerLegion_color_Emblem-120x80.jpg" class="entry-thumb wp-post-image" alt="" /></a>
<h2 class="entry-title"><a title="American Legion Post No. 129 to honor first  responders with dinner" href="http://queencreekindependent.com/community-event/american-legion-post-no-129-honor-first-responders-dinner/">American Legion Post No. 129 to honor first  responders with dinner</a></h2>
<div class="entry-meta">
08/25/2017 &middot; <a href="http://queencreekindependent.com/community-event/american-legion-post-no-129-honor-first-responders-dinner/#respond">0 Comment</a>	</div><!--end .entry-meta-->
</li>			
<li >
<a href="http://queencreekindependent.com/news/queen-creek-town-offices-close-labor-day-2/" rel="bookmark"><img width="120" height="80" src="http://queencreekindependent.com/wp-content/uploads/2015/05/Logo-QC-Entry-Monument-120x80.jpg" class="entry-thumb wp-post-image" alt="" /></a>
<h2 class="entry-title"><a title="Queen Creek town offices to close on Labor Day" href="http://queencreekindependent.com/news/queen-creek-town-offices-close-labor-day-2/">Queen Creek town offices to close on Labor Day</a></h2>
<div class="entry-meta">
08/25/2017 &middot; <a href="http://queencreekindependent.com/news/queen-creek-town-offices-close-labor-day-2/#respond">0 Comment</a>	</div><!--end .entry-meta-->
</li>			
<li class="last-entry">
<a href="http://queencreekindependent.com/news/registration-way-qcs-citizen-leadership-institute/" rel="bookmark"><img width="120" height="80" src="http://queencreekindependent.com/wp-content/uploads/2017/05/0525qc-CLI-graduates-group-COLOR-1-120x80.jpg" class="entry-thumb wp-post-image" alt="" /></a>
<h2 class="entry-title"><a title="Registration under way through Aug. 28 for QC’s Citizen Leadership Institute" href="http://queencreekindependent.com/news/registration-way-qcs-citizen-leadership-institute/">Registration under way through Aug. 28 for QC’s Citizen Leadership Institute</a></h2>
<div class="entry-meta">
08/24/2017 &middot; <a href="http://queencreekindependent.com/news/registration-way-qcs-citizen-leadership-institute/#respond">0 Comment</a>	</div><!--end .entry-meta-->
</li>			
</ul>		
<div class="single-ad">
<!-- /83779297/az-mediumrectangle-01 -->
<div id='div-gpt-ad-1430931892893-1' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430931892893-1'); });
</script>
</div>				</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div><!-- #post-10867 -->
<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//queencreekindependent.us8.list-manage.com/subscribe/post?u=c0b15575bb95f493b0c78850b&amp;id=a2502f855b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to the Queen Creek Independent weekly email newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_c0b15575bb95f493b0c78850b_a2502f855b" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<!--End mc_embed_signup-->
<div class="spacer_10"></div>
<div id="jp-relatedposts" class="jp-relatedposts" style="display: block;">
<h3 class="jp-relatedposts-headline">
<em>Comments</em>
</h3>
</div>
<div>
You are encouraged to leave relevant comments but engaging in personal attacks, threats, online bullying or commercial spam will not be allowed. All comments should remain within the bounds of fair play and civility. (You can disagree with others courteously, without being disagreeable.) Feel free to express yourself but keep an open mind toward finding value in what others say. To report abuse or spam, click the X in the upper right corner of the comment box.</div>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><div class="fb-comments" data-href="" data-numposts="3" data-width="375" data-colorscheme="light"></div>	
</div><!--end #content-->
<div id="sidebar">
<div class="widget-ads widget"><h3 class="ad-title">advertisement</h3>		
<!-- ROS top rectangle -->
<!-- /83779297/az-mediumrectangle-02 -->
<div id='div-gpt-ad-1430931892893-2' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430931892893-2'); });
</script>
</div>
</div>		
<div class="tj_widget_social">
<div class="social-icons">
<ul>
<li class="icon-rss"><a href="http://feeds.feedblitz.com/queencreekindependent">Subscribe to<br />RSS</a></li>
<li class="icon-twitter"><a href="http://twitter.com/QCIndependent">Follow on<br />Twitter</a></li>
<li class="icon-facebook"><a href="http://www.facebook.com/QueenCreekSanTanValleyIndependent">Join us on<br />Facebook</a></li>				
<li class="icon-enews"><a href="http://queencreekindependent.com/enewsletter/">Sign-up for<br />Newsletter</a></li>
</ul>
<div class="clear"></div>
</div>
</div><!-- .tj_widget_social -->
<div id="text-2" class="widget widget_text"><h3 class="widget-title">This Week’s Newspaper</h3>			<div class="textwidget"><a href="http://queencreekindependent.az.newsmemory.com/"><img src="http://queencreekindependent.az.newsmemory.com/newsmemvol2/arizona/queencreekindependent//prima/prima.jpg" alt=""></a></div>
</div><div class="widget-ads widget"><h3 class="ad-title">advertisement</h3>		
<!-- ROS bottom rectangle -->
<!-- /83779297/az-mediumrectangle-03 -->
<div id='div-gpt-ad-1430931892893-3' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430931892893-3'); });
</script>
</div>		
</div></div><!-- #sidebar -->
	</div><!-- #main -->
<div class="clear"></div>
<div class="footer-categories">
<ul>
<li><div class="menu-footer-container"><ul id="menu-footer" class="sf-menu"><li id="menu-item-666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-666"><a href="http://queencreekindependent.com/about/">About Us</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36"><a href="http://queencreekindependent.com/contact/">Contact Us</a></li>
<li id="menu-item-4275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4275"><a href="http://newszap.com/pyn/az/">Publish Your News</a></li>
<li id="menu-item-9831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9831"><a href="http://specialsections.newszap.com/SS/Tiles2.aspx?sortby=type2&#038;cat=Queen%20Creek%20Independent">Special Sections</a></li>
</ul></div></a></li>
</ul>
<div class="clear"></div>
</div><!-- .footer-categories -->
<div class="copyright">
<p>&copy; 2017 <a href="http://www.newszap.com/">Independent Newsmedia Inc. USA</a>. All rights reserved.</p>
<p><a href="http://www.theme-junkie.com">WordPress Theme</a> designed by <a href="http://www.theme-junkie.com">Theme Junkie</a></p>
</div><!-- .copyright -->
<div class="clear"></div>
</div><!-- #wrapper -->
<a id="back-to-top" href="#"></a>
<!--Plugin WP Missed Schedule 2013.1231.2013 Build 2014-09-13 Active - Tag 6707293c0218e2d8b7aa38d418ffa608-->
<!-- This website is patched against a big problem not solved from WordPress 2.5+ to date -->
<div style="display:none">
</div>
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-50786cb629e532c2" async="async"></script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201734'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-content/plugins/theme-junkie-shortcodes/assets/js/junkie-shortcodes.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Augaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://queencreekindependent.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1586322298303559&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.944929122925 seconds, on 25-08-17 5:09:14 --><!-- via php -->